Verfasst am:

Posted in: Computerwelt, Mein Leben

2 Komentare

Meta Infos

id="post-374">

Upgrade der Buffalo HS-DHGL mit einer WD10EADS

Dieser Tage muss man schon zu den Leuten gehören, die ihre 4 Wände nie verlassen, um es tatsächlich zu schaffen nicht mindestens 10 Werbeposter vom Media Markt zusehen, welche entweder einen 49€ Drucker oder eine gleich teure externe Festplatte zeigen. Naja oder man wohnt halt in einem Ort wo dieses Angebot nicht gilt Nach dem mir gestern nach dem 1000 Plakat endlich eingefallen ist das mein Netzwerkspeicher sich den Grenzen des unbefüllbaren nährt, habe ich dann auch mal in einen „Das-Nicht-Blöd-mein-Agenda-Laden-2010“-Markt gefunden um dort festzustellen, dass es nur eine Platte pro Person gibt.

Naja diese eine Platte dann nach Hause gebracht und angefangen aus dem Gehäuse zu befreien, was eigentlich ganz leicht ist, dankt diesem Thread und diesem Youtube-vid, habe ich freudig festgestellt, dass sich in der WD Elements eine WD10EADS befindet. Eine ganz normale 3,5“ Platte mit 32MB Cache und 7200rpm.

Viel schwieriger war es die Platte in der LinkStation zum laufen zu bekommen. Wenn man sie nur anstelle der alten einsetzt, dann kommt man nicht wie hier beschrieben in den EM Modus aus dem man dann nur noch die Firmware trüber klatschen muss und Schluss ist, sondern bekommt es mit einem „Hard Drive can not be recognized “ zu tun. Google hat mir leider nur Foren gefunden, in dehnen sie keine Lösung haben.

Also habe ich meinen Grips angeschaltet und einen ganzen Abend herum probiert, naja letzteres hat dann zum Ziel geführt. Ich habe die alte Platte im Prinzip gespiegelt und dann auf die neue gepackt und die Partitionen vergrößert.

Schritt für Schritt Anleitung:

Die alte Platte (in meinem Fall eine Samsung) backupen

Dazu muss man die an einen Linux-Rechner anschließen (geht sicherlich auch mit Windows aber ka wie). Praktischer weise hatte ich ja von der Externen-Platte einen SATA zu USB Converter.

Alle gemounteten Partitionen unmounten (waren 3 in meinem Fall {1,2,6} )

sudo umount /dev/sdbX

MBR sichern (Master Boot Record, die ersten 512 Bytes jeder HDD)

sudo dd if=/dev/sdb of=nas.mbr count=1 bs=512

Partitionstabelle sichern

sudo sfdisk -d /dev/sdb > nas.sf

Nun alle Partitionen sichern, die sicher-bar sind {1,2,6} 3 gibt es nicht 4 ist eine Knoten-Partition und 5 ist das Swap-File.

sudo partimgae

Nun die neue Platte anschließen und da ganze rückwärts (umounten nicht vergessen!)

sudo dd if=nas.mbr of=/dev/sdb

sudo sfdisk /dev/sdb < nas.sf

sudo partimage

Jetzt hat man ggf ganz viel freien Speicher auf der neuen Platte, den habe ich mit gParted erst der sdb4 zugewiesen und dann der sdb6.

Dann noch die Festplatte ein bauen und schon sollte es Funktionieren. Hat bei mir nicht irgend wie kam dann der „Fan Problem “ – Fehler, nach einem Reboot und einer neu Installation er Firmware war der dann auch weg. Jedenfalls kam das NAS im Gegensatz zum „Leere-Platte“ einbauen nun wenigstens so weit, dass man eine neue Firmware installieren konnte.

Das ganze wirft bei mir einige Fragen auf. Erstens dachte ich immer, dass die LiveSttions der alten generation von Chip booten, aber habe ja gesehn, dass da eine Parttion mit uBoot ist und Zweitens frage ich mich warum ich nicht in dem EM mode komme.

2 Komentare

  1. Michael sagt:

    Super Überlegung. Hatte auch das Problem und bin zu keinem Erfolg gekommen. Dann habe ich Deinen Text gelesen und das ganze mit Clonzilla 1 zu 1 gemacht. Klappt 1A.
    DANKE

  2. Michael sagt:

    Hatte ich vergessen zu schreiben. Hat zwar alles prima funktioniert aber er zeigt mir nicht die originale größe der neuen Platte an sondern nur die der alten :-(

Verfasse einen Komentar

Security Code: